Commit ae363b6e authored by Ricki Hirner's avatar Ricki Hirner

Update Kotlin, dokka, gradle plugin, build tools, target SDK

parent 8b47761b
buildscript {
ext.kotlin_version = '1.2.51'
ext.dokka_version = '0.9.16'
ext.kotlin_version = '1.2.61'
ext.dokka_version = '0.9.17'
repositories {
jcenter()
......@@ -9,7 +9,7 @@ buildscript {
}
dependencies {
classpath 'com.android.tools.build:gradle:3.1.3'
classpath 'com.android.tools.build:gradle:3.1.4'
classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
classpath "org.jetbrains.dokka:dokka-android-gradle-plugin:${dokka_version}"
}
......@@ -29,12 +29,12 @@ ext {
}
android {
compileSdkVersion 27
buildToolsVersion '28.0.1'
compileSdkVersion 28
buildToolsVersion '28.0.2'
defaultConfig {
minSdkVersion 19
targetSdkVersion 27
targetSdkVersion 28
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment